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Overview

Win-eXpose-I/O is a file I/O Tracing/Debugging SHAREWARE windows util. that lets you examine in 
real time what files each running application is using or trying to use.
Win-eXpose-I/O traces all the file activities in all the application and in all the different VM (even DOS 
boxes) and gives you a clear picture on problems troubleshooting (like where and what the hell is the 
help file / INI file that the application is using or complaining that is missing).

Win-eXpose-I/O is a MUST HAVE tool for anyone who is installing windows software on the computer or 
just trying to make sure the current software is working properly, Win-eXpose-I/O saves those HUGE 
amount of hours trying to configure new or existing software by letting you know in real time what files 
each application is using or seeking.

Win-eXpose-I/O application has a very intuitive and simple to operate user interface, yet a very 
powerful one that lets any user novice to guru use the program in just a meter of seconds, just run it and 
then activate the other applications and you will see on the Win-eXpose-I/O screen a real-time logging 
of all the file activities and their results.

Win-eXpose-I/O is also used as a GREAT performance improves by letting you know for each 
application all the file seeking failures (like searching for a file on the path) and then just by changing a 
few system settings like PATH or working directory you will gain a performance improvement.



How to view file operations status in real-time

Simply activate Win-eXplorer and then switch to another application and do there what ever you like, 
every file operation that the other
application(s) will conduct will be traced and logged in real-time on the Win-eXplorer application screen.



Why and how to register

Simply fill up the ORDER.TXT file and send it with the registration fee.

Registering brings with it a number of advantages.

 o All the Unregistered Copy notice will no longer appear.

 o You will receive a menual.

 o Next major version is sent automatically when it becomes available.

 o If you supplied an E-Mail account a notice for each version release will be sent to you.

 o You will have FREE technical support should you have any problems.

 o The sound that is being played every new 100 I/O operation that failed will be removed.

 o Your support will encourage me to continue to improve the products Win-eXpose-I/O

 o You will have the knowledge that you personally helped a fledgling software developer and furthered 
the SHAREWARE concept.

 o As I see it, by using this Win-eXpose-I/O software you are saving yourself a lot of trail and error hours 
trying to solve problems or just understand what is going wrong ( and on ) so this small registration fee is 
really a small one to pay comparing to the benefits that the product Win-eXpose-I/O brings you.

And Finally, as a registered user you will be automatically become a register user for ALL the new Win-
eXpose-I/O version without paying any more fees. So make sure you complete the registration form 
(ORDER.TXT) as completely as possible and sent it.

For your ease here is a copy of the file ORDER.TXT

Win-eXpose-I/O (R) version 1.01
Copyright (C) 1994 Yonat Dascalu.
All Rights Reserved

      Win-eXpose-I/O v1.01 ORDER FORM
Win-eXpose-I/O Copyright (C) 1994 Yonat Dascalu. All Rights reserved

Payment can be in Cash, money order & checks, Payments in checks must be in US dollars drawn on a 
US bank or Israeli shekels drawn on a Israeli bank, CASH payment can be in ANY currency whatsoever, 
and should be sent to:

Yonat Dascalu
10 Azmaut Street
Ness-Ziona 74010
ISRAEL

Please try to pay in cash for small orders, if you are paying with checks most of the money goes to the 
bank it self due to the bank commissions.

Site licenses:    a site license for Win-eXpose-I/O entitles an organization to receive one copy of the 
distribution package and duplicate the distribution disk for the specified number of copies.
all dollars are US dollars.



Win-eXpose-I/O Single Copy        ____        copies at $29 each = ______

Win-eXpose-I/O Site License
        2 to      9 computers: ____ computers at $22 each = ______
    10 to    24 computers: ____ computers at $17 each = ______
    25 to    49 computers: ____ computers at $14 each = ______
    50 to    99 computers: ____ computers at $12 each = ______
100 to 199 computers: ____ computers at $11 each = ______
          (more than 199 copies are negotiable)

                                                                                            Total payment                          ______

 (Just for example, if you would like to buy 15 copies then the Total payment
      will be :        15 copies x    17$    = 255 $
 )

3.5" disks are sent unless a 5.25" disk is requested.

Note: Please print your name/company name clearly as your
                            registration number will be based on it.

                        Name: ______________________ Date:___________

                  Company: _______________________________________

                  Address: _______________________________________

City, State, Zip: _______________________________________

                  Country: _______________________________________

              Day Phone: ______________    Eve:    _________________

Electronic Mail address: ________________________________

How did you hear about Win-eXpose-I/O? __________________________

Suggestions, changes or additions you would like to 
see in future versions ?

Comments:

Any questions about the status of the shipment of an order,
refunds, registration options, product details, technical support,
volume discounts, dealer pricing, site licenses, etc., must be
directed to :

Yonat Dascalu
10 Azmaut Street
Ness-Ziona 74010



ISRAEL

or by EMAIL to :
dascalu@math.tau.ac.il      (preferable)

OR

75037.725@compuserve.com

All of our software is user supported. Please help us by sending your
comments, suggestions, and changes or additions you would like to 
see in future versions. Please send us a report if you happen to
find a bug.



License Agreement

Win-eXpose-I/O (R) version 1.01
Copyright (C) 1994 Yonat Dascalu.
All Rights Reserved.

For ordering information, see the file ORDER.TXT.

                                                      Win-eXpose-I/O For Windows
                                                                Version 1.01
                                                                          License Agreement
                                                                       Effective Aug 27 1994 

 License Agreement

The use of Win-eXpose-I/O is subject to the following terms and conditions.

Title To The Licensed Software

Title to the licensed software is NOT transferred or sold to the end user.
The end user is granted a non-exclusive license to use the software
on a SINGLE computer or computer work station. EACH computer or computer work station must have its
own licensed copy of the software.

Copyright Protection

Win-eXpose-I/O is copyrighted material. It is protected by the copyright laws of the United States, the 
State of California, and other proprietary rights of Yonat Dascalu. You may not make any changes or 
modifications to Win-eXpose-I/O or this manual. You may not decompile, disassemble, or otherwise 
reverse-engineer the software in any way.

You may make copies of Win-eXpose-I/O only under the terms of the section entitled "Limited License To 
Copy The Licensed Software".

You may use Win-eXpose-I/O on a thirty (30) day trial basis only, provided you do not violate the 
protection afforded the licensed software by the copyright laws, and you agree to the terms of the license 
agreement. 
If you use Win-eXpose-I/O past the 30 day evaluation period you are
required to purchase it by paying the registration fee.

Limited Warranty

Yonat Dascalu does not warrant that the licensed software will meet your requirements or that the 
operation of the software will be ininterrupted or error free. The warranty does not cover any media or 
documentation which has been subjected to damage or abuse by you or others.
The software warranty does not cover any copy    of the licensed software which has been altered or 
changed in any way. In other words, there is no warranty either implied or expressed.

ANY IMPLIED WARRANTIES INCLUDING ANY WARRANTIES OF MERCHANTABILITY OR FITNESS 
FOR A PARTICULAR PURPOSE ARE LIMITED TO THE TERM OF THE EXPRESS WARRANTIES. 
Some States do not allow limitations on how long an implied warranty lasts, so the above limitation may 
not apply to you.

Other Warranties
The warranties set forth above are in lieu of any and all other express or implied warranties, whether oral, 
written, or implied, and the remedies set forth above are the sole and exclusive remedies.



Limitation Of Liability
Yonat Dascalu is not responsible nor liable in anyway for any problems or damage caused by the licensed
software that may result from using the licensed software. This includes, but is not limited to, computer 
hardware, computer software, operating systems, and any computer or computing accessories. End user 
agrees to hold Yonat Dascalu harmless for any problems arising from the use of the software.
Yonat Dascalu SHALL NOT IN ANY CASE BE LIABLE FOR ANY SPECIAL, INCIDENTAL, 
CONSEQUENTIAL, INDIRECT OR OTHER SIMILAR DAMAGES ARISING FROM ANY BREACH OF 
THESE WARRANTIES EVEN IF Yonat Dascalu OR ITS AGENTS OR DISTRIBUTORS HAVE BEEN 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. THIS AGREEMENT SHELL BE GOVERNED BY
THE LAWS OF ISRAEL AND SHELL INURE TO THE BENEFIT OF Yonat Dascalu AND ANY 
SUCCESSORS, ADMINISTRATORS, HEIRS, AND ASSIGNS. ANY ACTION OR PROCEEDING 
BROUGHT BY EITHER PARTY AGAINST THE OTHER ARISING OUT OR RELATED TO THIS 
AGREEMENT SHALL BE BROUGHT ONLY IN ISRAEL. 

In no case shall Yonat Dascalu's liability exceed the license fees paid for the right to use the licensed 
software, or a sum no greater than
one Dollar ($1.00), whichever is less.

Limited License To Copy The Software
You are granted a limited license to copy Win-eXpose-I/O ONLY FOR THE TRIAL USE OF OTHERS 
subject to the terms of this software license agreement described herein, and that the conditions 
described below are met.

 -> No fee, charge or other compensation may be accepted or requested by    anyone without the express 
written permission of Yonat Dascalu. 

 ->    Public Domain Disk Vendors May NOT CHARGE a fee for the Win-eXpose-I/O itself. However you 
may include Win-eXpose-I/O on a diskette/CD-ROM for which you charge a nominal distribution fee. The 
purchaser of said diskette must be informed in advance that the fee paid to acquire the diskette does 
NOT relieve said purchaser from paying the Registration Fee for Win-eXpose-I/O if said purchaser uses 
Win-eXpose-I/O.
          
->      The statement of shareware registration requirements MUST be printed on a label, or other form, 
that is directly attached to the distribution media.

 -> Operators of electronic bulletin board systems (Sysops) may post
Win-eXpose-I/O for downloading by their users without written permission
ONLY AS LONG AS THE ABOVE CONDITIONS ARE MET.    A fee may be charged for access to the BBS
AS LONG AS NO SPECIFIC FEE IS CHARGED FOR DOWNLOADING Win-eXpose-I/O files without first 
obtaining the express written permission from Yonat Dascalu to charge such a fee.

Evaluation and Registration

This is not free software.    This license allows you to use this
software for evaluation purposes without charge for a period of 30
days.    If you use this software after the 30 day evaluation period
a registration fee of 29 US Dollars is required.    Payment can be in
Cash, money order, checks Payments in checks must be in US dollars drawn on a US bank or Israeli 
shekels, cash payment can be in any currency. Payments should be sent to:

Yonat Dascalu
10 Azmaut Street
Ness-Ziona 74010
ISRAEL



Quantity discounts are available, as described in the section
Ordering Information/Order Form.    When payment is received you
will be sent a registration key to remove all unregistered messages and documentation and the next 
version of Win-eXpose-I/O.

One registered copy of Win-eXpose-I/O may either be used by a single person who uses the software 
personally on one or more computers, or installed on a single workstation used non simultaneously by 
multiple people, but not both.

You may access the registered version of Win-eXpose-I/O through a network, provided that you have 
obtained individual licenses for the
software covering all workstations that will access the software
through the network.



Print

Allows you to print the contents of the trace screen to your Windows printer.

To print the screen, select the Print option from the File menu.    



Print Preview

Allows you to print preview the contents of the trace before it goes to the printer.

To print preview, select the Print preview option from the File menu.    



Print setup

Allows you to setup your printing options.

To setup your printing, select the Print setup option from the File menu. 



Clear trace log

Allows you to erase the information that was traced so far and start a new trace session.

To clear the trace log, select the Clear trace log option from the File menu. 



Close

Allows you to close and save the current trace log file.

To close the trace log, select the Close option from the File menu. 



Exit

Exit allows you to exit Win-eXpose-I/O.

To exit Win-eXpose-I/O:

Select the Exit option from the File menu.



Next I/O operation
 
Allows you to see the next Input/Output operation that was done.



Prev I/O operation
 
Allows you to see the previos Input/Output operation that was done.



Oper
 
Allows you to set the focus on the part of the screen where detailed information about a specific I/O 
operation is presented.



List
 
Allows you to set the focus on the part of the screen where a list of all the traced I/O operation are 
presented.



Current open files
 
Allows you to see a list of all files that their open was monitored by the Win-eXpose-I/O but no close was 
monitored.
meaning see a list of all open files.



Pause trace
 
Allows you to pause the logging of I/O opeartions.



Resume trace
 
Allows you to resume the logging of I/O opeartions.



Filters
 
Allows you to define smart filters of what I/O operations will be displayed on the screen and traced.



Tool Bar

Toolbar allows you to display or hide the Win-eXpose-I/O's toolbar.    The    toolbar gives you quick mouse 
access to several of the Terminal Manager functions.



Status Bar

Status Bar allows you to display or hide the current screen's status bar.



Cascade

Allows you to resize and layer the Win-eXpose-I/O windows on the desktop, so that they overlap each 
other, with the title bar of each window remaining visible. 



Tile

Allows you to resize and arrange the open Win-eXpose-I/O    windows side by side in the Win-eXpose-I/O 
window. 



Arrange icons

Allows you to arrange the icons within the Win-eXpose-I/O window.



KRegistration

Use this screen after registering as a user, by filling the information on this screen all "Unregistered copy" 
messages will disappear.
On information how to register look at this help file under the "How to register" section.



KHelp

Using Help

To choose a Help topic:

Mouse                              Point to the underlined topic you want to view and click the mouse button.

                                                When the pointer is over an item you can choose, the pointer changes to 
a hand icon.

Keyboard                      Press Tab to move the highlight to the underlined topic you want to view, and
then press Enter.

To exit Help:

Mouse                        1      Point to the File menu and click the mouse button.

2      Choose the Exit command.

Keyboard                    1      Press Alt.
2      Type the letter F.
3      Type the letter X.



KAbout Win-eXpose-I/O...

Select the About Win-eXpose-I/O... option from the Help menu for more information about the program.    
Choose the OK button to continue.



Troubleshooting

If you experience difficulties using the Win-eXpose-I/O application, refer to the following items:

            Verify that the installation and setup verification steps have been successfully completed.

            Ensure that the line device=eXplorer.386 exist in your system.ini file under the [386Enh] section.

          Verify that the filters are defined correcty and the the "Pause trace" option wasn't set.

          Read all relevant help information.

          If you are working in Windows For Workgroups and no I/O                  
          operations are being logged on the Win-eXpose trace screen, you 
          have to turn off the "32bit file access option " there are two diffrent 
          ways to do it :

1. Go to the windows for workgroups control panel, click on 
                                the 386 enhanced icon, then on the <virtual memory> 
                                button ,and then on the <change> button and then uncheck 
                                the "use 32-bit file access" option nad then click on the 
                                <ok> button.

2. Start windows by typing insteded of WIN the command :
WIN /D:C

     If you have any problem what so ever with accessing the trace    
        files or activating the program, you may want to try the following:
 
        1. Delete the file WinExpIO.ini from the windows directory.
        2. Remove any *.wxi files in the installation directory.
        3. Check that there is a line in the system.ini file in the windows
              directory that loads the WinExpos.386 windows device driver.
        4. Check that the original product *.doc and *.txt are in the
                Win- eXpose-I/O installation directory.
        5. If you are hear some sounds being played while activating the
              problem, do be scarred, the sound is being played every time
              there are 100 new failed I/O operations on the machine, the
              sound playing is removed in the registered version.
        6. Check that you didn't run out of disk space.
        7. As a last resort, try to re-install the product.

 . Due to windows 3.1 limitations the list box that contains the list of I/O traces is limit for about 2000 lines,
that means that you can see only the first 2000 I/O operations from the time a new trace file is opened, 
still in the operation dialog you can see ALL the I/O operations by clicking on the F7, F8 keys or on the 
<- , -> bottons.
If you see that you reach the limit of 2000 you can always open a new trace file with another name and 
then the previos information will be kept a side.






